How to Create Proxy Lusca with Ubuntu 10.04

By | 12:45 AM Leave a Comment
How to Create Proxy Lusca with Ubuntu 10.04 pamarekjubata
How to Create Proxy Lusca with Ubuntu 10.04. Hello this time I want to share a tutorial how to make ubuntu 10:04 external proxy, the proxy is useful as mecache file so that user who has taken the internet file stored in the proxy and if no other clients are requesting the same file it will be in direct proxy to not to internet, this makes you a bandwidth-efficient and also files in the capture of the proxy has a local speed 100 mbps. It is amazing is not :)

Okay go ahead, you first have to install ubuntu server on a PC, and I ansumsikan you've connected properly and can ping www.google.com for example.

The steps:
1. Open PuTTY and enter into ubuntu server by entering your IP Proxy Ubuntu.
2. Typing your password and user ubuntu
3. Type sudo su and enter your root password ubuntu earlier.
4. Copy-paste the command line-a line below in PuTTY:
  • apt-get update
  • apt-get upgrade -y
  • apt-get dist-upgrade -y
  • apt-get install squid -y
  • apt-get install squid squidclient squid-cgi -y
  • apt-get install gcc -y
  • apt-get install build-essential -y
  • apt-get install sharutils -y
  • apt-get install ccze -y
  • apt-get install libzip-dev -y
  • apt-get install automake1.9 -y
  • wget http://proxy-ku.googlecode.com/files/LUSCA_FMI.tar.gz
  • tar xzvf LUSCA_FMI.tar.gz
  • cd LUSCA_FMI
  • make distclean
 5. After all the above is complete copy-paste the following command in PuTTY to compile:.

./configure --prefix=/usr --exec_prefix=/usr --bindir=/usr/sbin --sbindir=/usr/sbin --libexecdir=/usr/lib/squid --sysconfdir=/etc/squid --localstatedir=/var/spool/squid --datadir=/usr/share/squid --enable-http-gzip --enable-async-io=24 --with-aufs-threads=24 --with-pthreads --enable-storeio=aufs --enable-linux-netfilter --enable-arp-acl --enable-epoll --enable-removal-policies=heap --with-aio --with-dl --enable-snmp --enable-delay-pools --enable-htcp --enable-cache-digests --disable-unlinkd --enable-large-cache-files --with-large-files --enable-err-languages=English --enable-default-err-language=English --with-maxfd=65536

6. Then copy-paste the following command in PuTTY to compile LUSCA melaukan installation.
  • make
  • make install
7. Download squid.conf, storeurl.pl dan squid

    HERE

8. Run WinSCP and go to ubuntu server with root user and password created earlier.
  • copy file squid ke folder /etc/init.d
  • copy file squid.conf dan storeurl.pl ke folder /etc/squid
9. Then copy-paste the following command in PuTTY.
  • chmod +x /etc/init.d/squid
  • /etc/init.d/squid stop
10. Still on PUTTY, copy-paste the below commands one by one:
  • chown proxy:proxy /cache
  • chown proxy:proxy /etc/squid/storeurl.pl
  • chmod 777 /etc/squid/storeurl.pl
  • chmod +x /etc/init.d/squid
  • /etc/init.d/squid stop
  • squid -f /etc/squid/squid.conf -z
  • /etc/init.d/squid restart
11. Reboot the PC proxy
12.Setting Mikrotik let the request to the Internet are directed to the proxy

/ip firewall nat
add chain=dstnat action=dst-nat to-addresses=192.168.7.2 \
to-ports=3128 protocol=tcp dst-port=80,8080.3128 \
src-address==!192.168.7.0/24

/ip firewall mangle
add chain=postrouting action=mark-packet \
new-packet-mark=proxy-hit passthrough=no dscp=12

/queue tree
add name="A_HIT-Proxy" parent=lan packet-mark=proxy-hit limit-at=0 \
queue=default priority=8 max-limit=0 burst-limit=0 \
burst-threshold=0 burst-time=0s

13. If It checks if it is successful with whatismyip.com appears you are using an internal proxy Lusca

Good luck good luck :)

How to Create Proxy Lusca with Ubuntu 10.04 9 out of 10 based on 10 ratings. 9 user reviews.

0 comments:

Post a Comment